Get in touch
Back
Downtime

Services unavailable

Started 16 Oct at 04:53pm EDT, resolved 16 Oct at 04:57pm EDT.

invintory.com app.invintory.com
Resolved

All issues have been resolved.

Posted 16 Oct at 04:57pm EDT.
Created

An update resulted in our services unable to connect to the production database for a period of 4 minutes.

Posted 16 Oct at 04:53pm EDT.